Announcement

Collapse
No announcement yet.

Updating Firmware on Digital 6 Car Powerbase

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Updating Firmware on Digital 6 Car Powerbase

    Hello,

    I've returned to Scalextric after a good few years away and want to benefit from all the great new options that are available. I've purchased a new Scalextric Digital 6-car powerbase, SSDC software and a PC to C7042 USB cable (the cable I bought from the SSDC website).

    I connected everything up as instructed and was very pleased to see my PC showing my lap times (very exciting). I then wanted to update the firmware to enable the full range of functions available using the SSDC software working. Unfortunately that is when my struggles started. I followed the instructions given on the SSDC website exactly but kept getting the message 'Device identification failed. Incorrect response' (shown below). I definately remembered to start the powerbase with the up arrow pressed (lights all on as shown in the picture).





    I've tried using two different computers (high-spec Windows 8 64bit PC and Windows 7 64bit laptop). I have tried using the drivers automatically installed by Windows and manually updating the FTDI driver to the VCP version from www.ftdichip.com.

    Any help would be greatly appreciated.

  • #2
    Welcome, PJ!

    Well, that is interesting. I don't think I've seen that before.
    Just to be 100% sure, you are using the same com port that you use when running SSDC and getting lap times and such, right? It just seems like the message that pops up is something you might get when the firmware updater is talking to some other connected device.

    What firmware version does the base have already? You can see it when you plug in the tower it came with. Is it .85?

    Comment


    • #3
      Hi MrF, it's the same COM port (the only COM port) that I was using when getting lap times with SSDC.

      The current firmware is build 00.085.

      Comment


      • #4
        Yeah, I figured you were doing it right.

        It's possible that the cable is defective or damaged. It's possible for the RMS to work, reporting lap times and such, but the firmware update does not. I just didn't think that because I'm not familiar with that error and failure.

        I guess the next step is to contact the seller of your cable and report the problem, and see if a replacement cable will work.

        Comment


        • #5
          Thanks MrF, I've contacted SSDC and will see if they know of a solution.

          As you say the next step is to get another cable to prove/disprove whether that is the cause of the problems.

          ** UPDATE **

          I have a new cable which works a treat. The upload process went as expected and my powerbase is now on firmware version 1.09.

          Thanks for the help.
          Last edited by pjholliday; 08-01-2014, 04:53 AM. Reason: Add final conclusion to topic

          Comment

          Working...
          X