Announcement

Collapse
No announcement yet.

Need to count 6 lanes using 1 paraport

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • chenglaw
    started a topic Need to count 6 lanes using 1 paraport

    Need to count 6 lanes using 1 paraport

    I started off using UR30 with RMS which runs on COM1 but have been finding that the RMS hardware is not too reliable. So have switched to using Infra-red LEDs. Have managed to hook up the hardware to UR30 using the paraport and got 5 lanes working (Pins 10, 11, 12, 13 and 15) without any problems but the 6th lane is refusing to count (I used Pin 14). I was hoping to avoid adding another paraport if at all possible as it's rather difficult to get hold of a PCI Parallel Port card here. Alternatively if UR30 doesn't accept input from Pin 14, can I use any other pin? One other option I was thinking of is maybe use the existing serial port (COM1) for Lane 6 if it can work together with the paraport - would that be possible? Would appreciate advice from any one. Thanks

    Have just looked back through older threads, and have found the comment that it's possible to use Pins 1, 16 and 17 if the paraport was configured as "centronics" at BIOS level. I've gone into my PC's BIOS setup and can only find options for configuring the paraport as "Auto" "EPP" and "ECP". Now how do I get round this? I'm running 3.0.27 rev 5.
    Last edited by chenglaw; 08-30-2008, 09:59 AM.

  • chenglaw
    replied
    Yeah, you're right NZ - can't take the easy way out to just hook up the relay directly to the paraport. So a bit more work to rig up the circuit board drawn up by P. The consolation is that it makes getting suitable relays a lot easier as we would just need automotive headlight relays which are easily available and can handle just about any current motor on the market.

    Leave a comment:


  • SlotsNZ
    replied
    powering relays

    I do not think that you could get enough power from the paraport to trigger any usable relay. Paraports only put out a small amount of current at 5V.....and it just won;t be enough. Plus, you risk blowing up the paraport with regular draw of current at the upper limits of it's capability.

    Hence the circuit diagram that Pierrick has put out, to deliver 12V at sufficient amps (I am guessing 100ma?) to reliably trigger the 5amp capacity relays on his circuit.

    What I want to do is create a 3 lane board for use on 3 and 6 lane circuits The 2 lane can do 2, 4 and 8 lane citcuits, but there is "redundancy" on 3 lane circuits.

    I am also thinking, if people don't want bad start capability (dead track starting) then you could configure all lanes power through a single relay - put the relay immediately at the output of the power supply. For that I want a 20 or 25 amp relay, as most of our tracks run 25 amp variable voltage supplies.Mostly we only draw 4 or 5 amps, but occasionally guys put their Womps or other 4 - 6 amp draw motors on the track.

    Leave a comment:


  • chenglaw
    replied
    Yup, NZ, we seem to be looking at doing the same things for our tracks. Where track power control is concerned, we're thinking of hooking up 6 relays individually via the paraport to switch power on and off. Since UR30 provides for the power supply control pin to be "inverted", it'll be easy to wire up the paraport to the relay so that power will remain on unless it is switched off by the activation of the relay. Just need to find some suitable relays which will work on the 5 volts put through by the parallel port pin.

    Leave a comment:


  • SlotsNZ
    replied
    Lane power

    Hi Chenglaw,

    we're walking the same path...... Several months ago, an electronics thech. in our club made up 6 blank boards as per the design on the UR3.0 site, and finished one with components for me. The cables weren't labeled, and I needed 3 lanes not 2, so I tossed it on the back burner, as the guy had got too busy to come to club.

    Anyway, I just switched my software over to UR3.0 now I have a computer able to run it (1024 x 768 ) and have decided to get lane power running. I emailed the guy and he is ringing me this afternoon with a price and time to get some more boards finished. He said it's no problem to do some more.

    Once I find out more I will let you know. It may be that my testing will be of help, I can let you know what he charges me for the boards if you aren't able to make your own up, I may be able to airmail 3 finished boards over to you.
    I am thiking I ill mount a centronics "socket" underneath my track, and wire each pin such as timing, lane power etc through that, and just plug a regular printer cable into that socket.

    Leave a comment:


  • chenglaw
    replied
    Nope NZ, couldn't get it to work on LPT1: with any other pin than 10, 11, 12, 13 and 15. But the good news (for me) is that I managed to source a PCI paraport card and had that installed in our PC as LPT2: so we've got working Start Lights now. Also discovered that if you set Timing to Fast, the lights go directly from Red to Green, skipping Orange. If you want the lights sequence to go from Red to Orange and then Green, the Timing has to be set as Standard. Other than that, everything works well. We've also hooked up a set of lane-coloured indicator lights which light up whenever a car activates the counting sensor as a sort of visual confirmation that the lap is being counted. Next step - auto Lane Power Supply Control for shut-off at end of race and for false start penalties.

    Leave a comment:


  • SlotsNZ
    replied
    Just curious

    Did you ever resolve this one Chenglaw?

    Leave a comment:

Working...
X