Announcement

Collapse
No announcement yet.

Race Coordinator Arduino issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Race Coordinator Arduino issue

    Hey guys

    Just want to find out if any of you have also had this issue. I have a windows 7 pc with the latest Race Coordinator and for the lap timing I'm using an Arduino Uno with the sketch loaded on. Sometimes there are no issues, and we can go through a whole day without any problems. Other days, we have a "link protocol" issue, which can only be solved by restarting the PC.

    I have tried another Arduino board, same issue. I even tried another PC with both Arduino boards, and randomly they come up with the same issue...

    Any ideas?

  • #2
    Does unplugging and replugging the arduino fix the problem?

    Comment


    • #3
      Unfortunately not, the PC must be rebooted for it to function again.

      Comment


      • #4
        The software might have gotten corrupted somehow. You could try downloading a fresh copy of Race Coordinator, deleting the original copy from your computer and installing the new copy.
        Another possibility is that the driver for the Arduino Uno has gotten corrupted. In the case of many USB devices a driver is automatically installed on your computer the first time the device is plugged in, in other cases you have to load and install the driver yourself. The original driver will have to be deleted with the Arduino board unplugged. Plugging in the Arduino board should re-install the driver.
        Last edited by RichD; 09-01-2021, 06:58 AM.

        Comment


        • #5
          Your "link protocol" communication issue.......are you using a standard USB "printer" cable (USB A to USB B cable) from the computer port to the arduino? There is no adapter of any sort in between correct? I have seen RC give the said communication error on computers using an an adapter of some sort.

          Plus I have seen the same error when there is EMI issues. Arduino is very sensitive to EMI so make sure you are using a good quality shielded USB printer cable, this is a must. I have seen cheap printer cables cause this same issue. Careful how you route your Arduino cable so the cable is not attached to power lines. Many higher cost vendors supply a very good shielded USB cable with the Arduino but less expensive vendors do not.
          I have also seen this error on a PC that had an overnight automatic windows upgrade. It's a good idea to write down what port # your Arduino is configured to on the RC Track Setup page.

          It is usually something very simple so hopefully it is the case with you.
          Rob
          Last edited by cgyracer; 08-30-2021, 09:19 AM.

          Comment

          sex vidio
          antalya escort
          lara escort escort istanbul escort sirinevler escort antalya
          beylikduzu eskort bayan taksim eskort lara eskort bayan bakirkoy bayan eskort
          gaziantep escort gaziantep escort
          izmir escort kayseri escort gaziantep rus escort
          replica watches
          kadikoy escort kartal escort
          eurocasino
          hd porn
          Working...
          X